PostgreSQLの脆弱性情報(CVE-2020-1720)と新バージョン(9.6.17, 10.12, 11.7, 12.2)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

02/14/2020にPostgreSQLの脆弱性情報(CVE-2020-1720)と新バージョン(9.6.17, 10.12, 11.7, 12.2)が公開されました。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




CVSS/一次情報源

CVE番号 影響するバージョン リファレンス Priority CVSS
CVE-2020-1720 postgresql < 9.6.17, 10.12, 11.7, 12.2

PostgreSQL 12.2, 11.7, 10.12, 9.6.17, 9.5.21, and 9.4.26 Released!

Vendor: 3.1

Vendor: Vector: AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

[参考]


セキュリティ系連載案内

セミナー情報1

2/26(水) 19:00から21:00で、恵比寿のRed Hat様(会場)にてOSSセキュリティ技術の会 第八回勉強会「KeycloakとmidPointの2000万パワーズの巻(仮)」を開催致します。

今回は、KeycloakやmidPointをテーマとし、さらに、Red Hat系のディープな技術者が集まるカンファレンスであるdevconf.czが1月末に開催され、最新のコンテナセキュリティからKeycloakまでセキュリティに関するトピックも扱われました。devconf.czに参加・講演して得られた情報の共有もいたします。

プログラム内容と申し込みの詳細につきましては、こちら(connpass)を御確認下さい。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

OpenVPNの脆弱性情報(CVE-2020-8953)

次へ

sudoの脆弱性情報(Important: CVE-2019-18634)