pythonの脆弱性(CVE-2018-1060, CVE-2018-1061)




03/03/2018にpythonの脆弱性情報(CVE-2018-1060, CVE-2018-1061)が公開されていました。遅くなってしまいましたが、今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。


こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/03/2018にpythonの脆弱性情報(CVE-2018-1060, CVE-2018-1061)が公開されていました。遅くなってしまいましたが、今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Moderate(CVE-2018-1061), Low(CVE-2018-1060)

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1060
    • DoSを発生させる可能性

    • 重要度 - Low

    • 2.7.15, 3.4.9, 3.5.6, 3.7.0 以前のバージョンのpythonでは、pop3libのapop()バックトラッキング脆弱性があり、攻撃者はこれを利用してシステムにDoSを仕掛けることが出来る可能性があります。

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1061
    • DoSを発生させる可能性

    • 重要度 - Moderate

    • 2.7.15, 3.4.9, 3.5.6, 3.7.0 以前のバージョンのpythonでは、difflib.IS_LINE_JUNKメソッドにバックトラッキング脆弱性があり、攻撃者はこれを利用してシステムにDoSを仕掛けることが出来る可能性があります。



対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteやKatello、Spacewalk等を使うと管理が便利でしょう。

また、OSの再起動が発生しますので、peacemakerなどOSSのクラスタ製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

Catastrophic backtracking in poplib (CVE-2018-1060) and difflib (CVE-2018-1061)

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1060

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1061

セキュリティ系連載案内


セミナー情報

2018年07月13日 (金) 19:00から、「OSSセキュリティ技術の会 第三回勉強会 (副題:"Keycloak"で、"認証王"に!!!おれはなるっ!!!!)」 と題しまして、OSS認証基盤のKeycloakに特化した話をさせて頂きます。

https://secureoss-sig.connpass.com/event/90917/がプログラム内容と申し込みの詳細になりますので、是非お申し込み下さい。

前へ

389-ds-baseの脆弱性(CVE-2018-10850)

次へ

GlusterFSの脆弱性(CVE-2018-10841)