ruby gem Net::LDAPの脆弱性 (CVE-2017-17718) — | サイオスOSS | サイオステクノロジー

ruby gem Net::LDAPの脆弱性 (CVE-2017-17718) — | サイオスOSS | サイオステクノロジー
現在位置: ホーム / セキュリティ ブログ / ruby gem Net::LDAPの脆弱性 (CVE-2017-17718)

ruby gem Net::LDAPの脆弱性 (CVE-2017-17718)

12/17/2017にrubyのgemライブラリであるNet::LDAPの脆弱性情報(CVE-2017-17718)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

12/17/2017にrubyのgemライブラリであるNet::LDAPの脆弱性情報(CVE-2017-17718)が公開されています。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



一次情報源

必ず一次情報源も御確認ください。

LDAPS vulnerable to MITM - failure to validate hostname against CN or SAN in X509 Cert #258


Priority

Moderate

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

[参考]

LDAPS vulnerable to MITM - failure to validate hostname against CN or SAN in X509 Cert #258

セキュリティ系連載案内

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

タグ:
----- EXTENDED BODY:

前へ

MIT Kerberosの脆弱性情報(CVE-2018-5709, CVE-2018-5710) — | サイオスOSS | サイオステクノロジー

次へ

広範囲のSambaに複数の脆弱性(CVE-2017-14746, CVE-2017-15275) — | サイオスOSS | サイオステクノロジー