Sambaの複数の脆弱性情報(Medium: CVE-2021-20254 と修正バージョン(4.14.4, 4.13.8, 4.12.15)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

04/29/2021に、Sambaの複数の脆弱性情報(Medium: CVE-2021-20254 と修正バージョン(4.14.4, 4.13.8, 4.12.15)が公開されています。今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。





CVSS/プライオリティ

CVE番号 影響するバージョン リファレンス Priority CVSS3 Base Score CVSS3 Basic Metrics
CVE-2021-20254 3.6.0以降の全てのSamba CVE-2021-20254

Vendor: Medium

Vendor: 6.8

Vendor: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2021-20254
    • Negative IDMap Cacheに起因するSambaファイルサーバプロセスtokenの不正なグループエントリの生成
    • 重要度 - Medium
    • 影響を受けるバージョン: Samba 3.6.0以降
    • SIDからgidへの変換の際のコード上のエラーにより、期待しないグループエントリをプロセストークン中に許可してしまいます。これによりファイルへの認証されていないアクセスを許してしまう可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、サービスの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。


セキュリティ系連載案内

CM

こちらで小学生の勉強支援サイトをオープンしました。算数のプリント(都度、自動生成)が無料でダウンロードできます。コンテンツは未だ少ないですが、徐々に増やしていきます。


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

BIND 9の複数の脆弱性情報(Medium: CVE-2021-25214, High: CVE-2021-25215, CVE-2021-25216)と新バージョン(9.11.31, 9.16.15, 9.17.12 )

次へ

Rocky Linux 8.3 Preview版のリリース