Sambaの脆弱性情報(Moderate: CVE-2021-20316)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

01/10/2022に、Sambaの脆弱性情報(Medium: CVE-2021-20316が公開されています。今回はこちらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。





CVSS/プライオリティ

CVE番号 影響するバージョン Priority CVSS3 Base Score CVSS3 Basic Metrics
CVE-2021-20316 Samba < 4.15.0

Vendor: 5.9

Vendor: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:N/E:P/RL:O/RC:C/CR:M/IR:M/AR:X/MAV:N/MAC:H/MPR:L/MUI:N/MS:C/MC:H/MI:H/MA:N

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2021-20316
    • Symlink競合エラーによるexportされた共有以外のメタデータへの読み込み/修正
    • 4.15.0より前のSambaでは、SMB1またはNFSのSymlink競合により、共有設定で定義されている以外のSambaサーバ上のメタデータにアクセスされる可能性があります。メタデータはタイムスタンプ/所有者/属性/拡張属性などを含みます。この攻撃を成功させるためには、サーバ上でSMB1又はNFSが有効になっている必要があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。

また、サービスの再起動が発生しますので、pacemakerなどOSSのクラスタ製品やLifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

日々のメモを更新しています。

セキュリティ関係ニュースを更新しています。個別で情報出せるようになる前の簡単な情報・リンクなんかも載せていきます。

前へ

containerdの脆弱性(High: CVE-2021-43816)と新バージョン(v1.5.9)

次へ

Linux Kernelの脆弱性(Important: CVE-2021-4155)