Apache Tomcatの脆弱性情報(Important: CVE-2020-11996)と新バージョン(10.0.0-M6/9.0.36/8.5.56)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

06/26/2020にApache Tomcatの脆弱性情報(Important: CVE-2020-11996)と新バージョン(10.0.0-M6/9.0.36/8.5.56)が公開されています。今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




一次情報源

CVE番号 影響するバージョン リファレンス Priority CVSS
CVE-2020-11996 10.0.0-M1 - 10.0.0-M5, 9.0.0.M1 - 9.0.35, 8.5.0 - 8.5.55

HTTP/2 DoS CVE-2020-11996

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11996
    • HTTP/2によるDoSの可能性
    • 特別に細工されたHTTP/2リクエストのシーケンスにより数秒間CPU使用率を高くすることが出来ます。そのようなリクエストがHTTP/2の同時接続で充分な数になった時、サーバは応答しなくなります(DoS)。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

BIND 9の複数の脆弱性情報(Medium: CVE-2020-8618, CVE-2020-8619)と新バージョン(9.11.20, 9.16.4, 9.17.2)

次へ

Sambaの複数の脆弱性情報(CVE-2020-10730, CVE-2020-10745, CVE-2020-10760, CVE-2020-14303)と修正バージョン(4.12.4, 4.11.11, 4.10.17)