Apache Tomcatの脆弱性情報(Moderate: CVE-2020-17527)

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

12/03/2020にApache Tomcatの脆弱性情報(Moderate: CVE-2020-17527)が公開されています。今回はこれらの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




一次情報源

CVE番号 影響するバージョン リファレンス Priority CVSS
CVE-2020-17527 10.0.0-M1 - 10.0.0-M9, 9.0.0.M1 - 9.0.39, 8.5.0 - 8.5.59

Moderate: HTTP/2 request mix-up

Vendor: Moderate

-->

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-17527
    • 情報漏えいの可能性
    • 64830の問題を調査している際に、HTTP/2接続で直前に受け取ったストリームの後続に関連付けられたHTTPリクエストヘッダの値を再使用することが出来ることがわかりました。これによりエラーが発生してHTTP/2接続が閉じられる可能性が高くなりますが、リクエスト間で情報が漏洩する可能性があります。

主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat SatelliteKatello、Spacewalk等を使うと管理が便利でしょう。


セキュリティ系連載案内


OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

前へ

Linux Kernelの脆弱性(Moderate: CVE-2020-27786)

次へ

マルチテナントクラスタに影響するKubernetesのMan-In-the-Middle 脆弱性情報(Moderate: CVE-2020-8554)